Portal Access has been degraded

Incident Report for Buckzy Platform Status

Resolved

This incident has been resolved.
Posted Mar 14, 2022 - 08:24 EDT

Investigating

We are experiencing elevated errors from our customer facing portals. We are diligently investigating and expect to have resolution shortly
Posted Mar 13, 2022 - 18:29 EDT
This incident affected: Customer Portals.